>

www.bifa688.com04下安装QT集成开荒条件,操作系统为

- 编辑:www.bifa688.com -

www.bifa688.com04下安装QT集成开荒条件,操作系统为

在Ubuntu下装了QT4.6 SDK,可以参考在Ubuntu下安装*.sh和*.bin的方法。

在安装QT集成开发工具包之前需要先安装build-essential和libncurses5-dev这两个开发工具和库,libncurses5-dev库是一个在Linux/Unix下广泛应用的图形函数库,build-essential里面包括一些Linux下开发的必要工具。

在安装QT集成开发工具包之前需要先安装build-essential和libncurses5-dev这两个开发工具和库,libncurses5-dev库是一个在Linux/Unix下广泛应用的图形函数库,build-essential里面包括一些Linux下开发的必要工具。在ubuntu中我们使用QT进行开发也用到了这两个工具库。安装命令为:sudo apt-get install build-essential libncurses5-dev。

首先去QT官网去下载一个QT的SDK

在Ubuntu中我们使用QT进行开发也用到了这两个工具库。

在这个库安装完成后就可以安装QT开发工具包了,具体安装步骤如下:

安装命令为:sudo apt-get install build-essential libncurses5-dev。

1、下载QT SDK安装包。

比如是qt-sdk-linux-x86-opensource-2009.05.bin

在这个库安装完成后就可以安装QT开发工具包了,具体安装步骤如下:

2、在安装包所在路径执行命令:

给下来的文件加上可执行权限

1、下载QT SDK安装包。

sudo chmod u x qt-sdk-linux-x86-opensource-2010.04

cd 到文件所在的目录

2、在安装包所在路径执行命令:

sudo ./ qt-sdk-linux-x86-opensource-2010.04

chmod u x qt-sdk-linux-x86-opensource-2009.05.bin

sudo chmod u x qt-sdk-linux-x86-opensource-2010.04

3、安装完成后编译一个自带的例子,看是否能够正常编译运行,如果能够运行则证明已经安装成功。

然后./qt-sdk-linux-x86-opensource-2009.05.bin

sudo ./ qt-sdk-linux-x86-opensource-2010.04

 

这样就能看到熟悉的安装了。

www.bifa688.com,3、安装完成后编译一个自带的例子,看是否能够正常编译运行,如果能够运行则证明已经安装成功。

www.bifa688.com 1

www.bifa688.com 2

本文由bifa688.com发布,转载请注明来源:www.bifa688.com04下安装QT集成开荒条件,操作系统为